Predator Software Windows Requirements

We know our customers have different versions of Windows on their computers and they also questions if they will be able to run Predator Software on them. We hope you will find the information on this page useful.

Support for the following Microsoft Windows editions are included with all Predator applications:

  • Windows 2016 Server – Requires Predator v11
  • Windows 10 – Requires v11
  • Windows IoT Enterprise – Requires v11
  • Windows 2012 Server
  • Windows Embedded 8 and 8.1
  • Windows 8
  • Windows 7
  • Windows Embedded 7
  • Windows Embedded Standard 2009
  • Windows 2008 Server

NOTE: Predator MDC Executive v11 and Predator FLM v11 do not support Windows XP or Windows 2003 Server. This is primarily due to security requirements.

Predator applications support 32 bit and 64 bit Windows editions. The latest service packs for each OS should be installed. In addition, Predator applications support Windows Terminal Services and Citrix MetaFrame. Within these thin client environments, Predator applications require Predator FLM.

NOTE: Different versions of Predator applications require different versions of the .Net Framework. All Predator installs include the appropriate.Net Framework versions automatically.

NOTE: Specific OEMs or large accounts that have highly customized editions of Windows may introduce specific compatibility issues with Predator applications.

Previous versions of Predator applications supported previous versions of Windows. Existing customers running Windows 3.1, Windows 95, Windows 98, Windows ME, Windows NT or Windows 2000 must upgrade to a newer OS prior to upgrading Predator.

Predator Secure Applications

Support for the following Microsoft Windows editions are included with all Predator Secure applications:

  • Windows 2016 Server
  • Windows 10
  • Windows IoT Enterprise
  • Windows 2012 Server
  • Windows 8
  • Windows Embedded 8 and 8.1
  • Windows 7
  • Windows Embedded 7
  • Windows Embedded Standard 2009
  • Windows 2008 Server
  • Windows Vista
  • Windows 2003 Server
  • Windows XP
  • Windows XP Embedded
  • Windows 2000 Server and Professional
  • Windows ME
  • Windows NT 4.0, 3.51 and 3.5
  • Windows NT Embedded 4.0
  • Windows 98
  • Windows 95

NOTE: Includes support for 32 bit and 64-bit editions. The latest service packs for each OS should be installed.

Incompatible Windows Editions

Over the years, Microsoft has released a wide range of Windows editions. The following list of Windows editions are incompatible with Predator applications and utilities:

  • Windows 10 S
  • Windows 10 IoT Mobile Enterprise
  • Windows 10 IoT Core
  • Windows RT
  • Windows Embedded 8 Standard
  • Windows Embedded Compact 7
  • Windows Embedded Compact 2013
  • Windows Embedded CE
  • Windows CE
  • Windows Mobile 6.5, 6.1 and 6.0
  • Windows Mobile 5
  • Windows Mobile 2003 and 2003 SE
  • Windows Pocket PC 2002 and 2000
  • Windows NT Alpha

NOTE: Not all incompatible Windows editions are listed. Many of the above editions use non-x86 style processors or are too niche to be supported by Predator Software.

NOTE: Includes support for 32 bit and 64 bit editions. The latest service packs for each OS should be installed. Specific OEMs that have highly customized editions of Windows may have introduced specific compatibility issues with Predator applications. Previous versions of Predator applications supported previous versions of Windows. Existing customers running Windows 3.1, Windows 95, Windows 98, Windows ME, Windows NT or Windows 2000 must upgrade to a newer OS prior to upgrading Predator.

NOTE: Predator v9 applications require the .Net 2.0 runtime while most v10 applications require the .Net 3.5 runtime with the exception of Predator CNC Service v10 and Predator Import Service v10 which requires .Net 4.5 runtime. Finally, Predator FLM v10 requires .Net 3.5 runtime and .Net 4.0 runtime. Predator MDC Executive v11 requires .Net 4.5 runtime. All Predator installs include the appropriate .Net runtimes automatically.

Please call (877) 611-5825 or fill out a Support contact form.